Cannot modify header information问题的解决方法

昨晚升级WordPress 2.5.1 ,记事本编辑了wp-config-sample.php为wp-config.php,结果登录管理页面/wp-admin/时遭遇如下问题:

Warning: Cannot modify header information - headers already sent by ……

搜索“Cannot modify header information”得到一票解决方法,简单说就是拿记事本编辑的php文件不是UTF-8(无BOM)编码的,更改php文件还是用Notepad++(这是一款主页上抵制北京奥*运的软件,囧)或UltraEdit靠谱。

切换编码

切换编码后保存,再上传就可以解决问题。